Monday, February 4, 2008

Microsoft.XLANGs.Core.UnexpectedMessageTypeException: Received unexpected message type '' does not match expected type

Just drop a quick note on this.

If you ever find this BizTalk exception where you so sure that you didn't change anything and it just happens after you deploy your orchestration :
Check your pipeline settings in your send port, it might have changed into PassThruTransmit/PassThruReceive instead of XmlTransmit/XmlReceive.

Not sure why it's changed, but this sometime happens after re-deploying orchestration.

Another 2 hours wasted because of this :(

18 comments:

Anonymous said...

Thank you. It saved me some time.

simha said...

Thank You. I waste 4 hours for fixing this. After seeing u r post i got it fixed.

-Simha

Bembeng Arifin said...

Hi Simha,
Glad it helped ;)

Anonymous said...

got damn!!! thank you!! used several hours on this shit... :p

Bembeng Arifin said...

haha welcome aboard, we feel your pain ;)

Anonymous said...

I think that Biztalk errors are not explicit at all. Often the error messages are of very little help and we lose hours finding the real problem. Thanks you Arifin for this post which gave me the solution to my porblem. Keep It Up :)

Shah MOHAMOD

Anonymous said...

i have spent hours try to find out why the heck i was getting this error. Thank you for posting this solution.

Joe Heron said...

Like everyone else I just blew 3 hours trying to figure this crap out. Thanks for the post!

Anonymous said...

Thanks dude, I was stuck for hours till i got here...
Thanks again!

Praveen said...

Thanks a lot

Max said...

I had got the same problem. In my case i entered incorrect table name in SQL transport options - BizTalkLog instead of BiztalkLog.

Anonymous said...

Thanks a lot, very very helpful.. :)

Amit said...

hi,
we have one application and we created second one with version 2.
we deployed version 2 on top-of version one. if i post documents for version 2 it works fine but if i post documents for version one i am getting below error messages,
Microsoft.XLANGs.Core.UnexpectedMessageTypeException: Received unexpected message type 'LSC.FundingData.Import.DLF.Orchestrations.SSoADataImportService.Reference+AdultSSoAData,
LSC.FundingData.Import.DLF.Orchestrations, Version=2.0.0.0, Culture=neutral, PublicKeyToken=82632b94b069a919'
does not match expected type '
LSC.FundingData.Import.DLF.Orchestrations.SSoADataImportService.Reference+AdultSSoAData,
LSC.FundingData.Import.DLF.Orchestrations, Version=1.0.1.0, Culture=neutral, PublicKeyToken=82632b94b069a919'.

at Microsoft.XLANGs.Core.XMessage._verifyPublisherSchema()

at Microsoft.XLANGs.Core.XMessage.FetchProperties()

at Microsoft.BizTalk.XLANGs.BTXEngine.BTXPortBase.ReceiveMessage(Int32 iOperation, Envelope env, XLANGMessage msg, Correlation[] initCorrelations, Context cxt, Segment s)

at LSC.FundingData.Import.DLF.Orchestrations.DLFAdultFundingDataImport.segment6(StopConditions stopOn)

at Microsoft.XLANGs.Core.SegmentScheduler.RunASegment(Segment s, StopConditions stopCond, Exception& exp)
Microsoft.XLANGs.Core.UnexpectedMessageTypeException
Scoped@
DLFAdultFundingDataImport.??__scope34
DLFAdultFundingDataImport.??__scope33
DLFAdultFundingDataImport.DLFAdultFundingDataImport
20d2d333-4794-4976-a37d-21544dfe0587

not able find out where is the problem...
please help if you know...

Anonymous said...

Check the Vishnu's solution:
http://social.msdn.microsoft.com/Forums/en/biztalkgeneral/thread/4a9623d8-5b0d-45ce-89b9-99ff46464615?prof=required

Anonymous said...

solved my problem biztalk 2010 - i somehow exported the binding when it was incorrect, so i was always importing it incorrect.

cyrus

Anonymous said...

Thanks!

Anonymous said...

I blew 4 hours. TQVM.

Veena Dubey said...

Its solved my problem.................. Thanks

Post a Comment